Skip to main content

Downloads

Downloads

Software

Saffire 6 USB 1.1 Drivers - Mac (OS 10.11.2 El Capitan - macOS 10.14.6 ONLY)

Mac only.

This driver will only work with the USB 1.1 version of the Saffire 6 USB (units with a USB port labelled "USB" or "USB 1.1").

Release notes:
- Updated driver for use on Mac OS 10.11 (El Capitan)

Please note:
- This driver requires OS X 10.11.2 or above. It will not work with earlier versions of OS X (including earlier releases of 10.11)
- This driver and the Saffire 6 USB 1.1 will not work macOS Catalina

Saffire 6 USB Drivers - Mac (please see details below)

This is a Mac only release.

 

THIS VERSION OF THE DRIVER REQUIRES OS 10.9 or 10.10. If you are running an older version of OSX, please click HERE.

 

If you are using the USB 2.0 version of the Saffire 6, no driver is required. Simply plug and play.

 

If you are using the USB 1.1 version of the Saffire please download and install the driver below.

 

If you are unsure whether your unit is the USB 1.1 or 2.0 version please check the text below the USB port on the back of the device.

 

Fixes

- Updated driver signing for use on Mac OS 10.10 (Yosemite)

Saffire 6 USB Drivers - Windows (please see details below)

Focusrite USB 1.1 Driver – Win(1.10)

For Saffire 6 USB units with "USB" or "USB 1.1" printed under the USB connector on the back.